一半君的总结纸

听话只听一半君

CentOS 7 降级NVidia 驱动 从340.32到331.79

不知道从什么时候开始休眠突然不能用了,pm-hibernate之后屏幕变黑,光标在左上角闪烁,但是就这样一直下去了,怀疑和最近升级的NVidia驱动有关

在hibernation log里

cat /var/log/pm-hibernate.log

没看到哪里不正常的,全文在这里
ps: 不知道为何后几次试验(执行命令pm-hibernate),都是在pm-suspend.log里,在这里
如果我从“开始菜单”里选leave->Hibernate, 似乎log本应在pm-powersave.log里,因为这个文件的最后修改时间恰好是选择hibernate菜单的时候,但是这个文件是0k

联想到最近好像yum有升级NVidia驱动,查看下历史

[fucker@localhost sender]$ sudo cat /var/log/yum.log | grep nv
Jul 19 12:31:18 Installed: kmod-nvidia-340.24-1.el7.elrepo.x86_64
Jul 19 12:32:19 Installed: nvidia-x11-drv-340.24-1.el7.elrepo.x86_64
Jul 20 16:04:04 Installed: perl-Env-1.04-2.el7.noarch
Aug 24 11:30:43 Updated: kmod-nvidia-340.32-1.el7.elrepo.x86_64
Aug 24 11:30:51 Updated: nvidia-x11-drv-340.32-1.el7.elrepo.x86_64

在上面看到最近有升级到 340.24, 但是我记得好像不能休眠很久了已经,先看看Repo上有没有能降的版本

[fucker@localhost sender]$ yum --showduplicates list kmod-nvidia
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: centos.mirror.secureax.com
 * elrepo: mirrors.thzhost.com
 * epel: mirror.nus.edu.sg
 * extras: centos.mirror.secureax.com
 * updates: centos.mirror.secureax.com
Installed Packages
kmod-nvidia.x86_64                                           331.79-2.el7.elrepo                                            @elrepo
Available Packages
kmod-nvidia.x86_64                                           331.79-2.el7.elrepo                                            elrepo
kmod-nvidia.x86_64                                           331.89-1.el7.elrepo                                            elrepo
kmod-nvidia.x86_64                                           340.24-1.el7.elrepo                                            elrepo
kmod-nvidia.x86_64                                           340.32-1.el7.elrepo                                            elrepo

乱搞试下,降到331.79-2看行不行

# 先把旧的删了
yum remove nvidia-x11-drv kmod-nvidia

# 再装旧的,似乎他会知道nvidia-x11-drv是需要的依赖
yum install  kmod-nvidia-331.79-2.el7.elrepo

重启后依旧不行,看来和这个没关系哈… orz

如果搜关键词kernel 3.10 hibernation bug会有很多结果,而我的是

[fucker@localhost sender]$  uname -r
3.10.0-123.el7.x86_64

难道只能静待日后升级解决么

edit2: 1小时后发现他自己莫名其妙的又可以休眠了,我了个大擦 orz …

Advertisements

发表评论

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / 更改 )

Twitter picture

You are commenting using your Twitter account. Log Out / 更改 )

Facebook photo

You are commenting using your Facebook account. Log Out / 更改 )

Google+ photo

You are commenting using your Google+ account. Log Out / 更改 )

Connecting to %s

%d 博主赞过: